Elementary OS Loki on MSI GL62 Laptop

Home » Computer Articles » Linux » Elementary OS Loki on MSI GL62 Laptop
May 31, 2017 Linux No Comments

I wanted to see if I could install Linux Desktop on my MSI GL62 Laptop. So here is some basic steps I needed to take to make it work.

 

Created a bootable USB key with Elementary OS on it.

 

This setup even works with UEFI, you may need to disable the secure boot.

 

Boot from USB key but you will need to either disable ACPI or add some ACPI settings.

 

When you are boot linux and at the Grub menu, hit e to edit and then add below after the quiet entry.

acpi_osi='!Windows 2012'

or

acpi_osi=! acpi_osi='Windows 2009' (I tried this first, then I found out I should be using above.)

 

Once the laptap is booting up you will need to add the information above to Grub.

# nano /etc/defaults/grub

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2012' quiet splash"

# update-grub

The system should boot, shutdown, and reboot properly.

 

 

Everything seems to be working properly. I did all the updates etc and install application I thought I would need. All though I thought the camera wasn't working. Found out you need to enable it on the keyboard and then it works properly.

Even Audioquest Dragonfly v1.5 dac worked for me.  Much better sound quality then the onboard sound card. Well of course that is my opinion.

 

UPDATE: I wanted to use a Bluetooth mouse, the gui never seem to find any devices. I had to use the command line to finally see any devices.

Here are some of the commands I used. Not all together sure what command made things work.

# bluetoothctl
[bluetooth]# list
Controller <controller mac> [default]
[bluetooth]# select <controller mac>
[bluetooth]# power on
[bluetooth]# scan on
[bluetooth]# agent on
[bluetooth]# devices
Device <mouse mac> Name: Bluetooth Mouse
[bluetooth]# pair <mouse mac>
[bluetooth]# trust <mouse mac>
[bluetooth]# connect <mouse mac>

I had some commands above that didn't work, example when I typed pair there seemed to be a connection error.

I used this website to help with the Bluetooth problem: https://wiki.archlinux.org/index.php/bluetooth_mouse

 

Reference:
https://github.com/Bumblebee-Project/Bumblebee/issues/764
https://wiki.manjaro.org/index.php?title=Optimized_power_settings
https://github.com/Bumblebee-Project/bbswitch/issues/140
https://askubuntu.com/questions/838212/ubuntu-16-10-fails-to-boot-in-msi-gp72-laptop/838369
https://ubuntuforums.org/showthread.php?t=2328462&page=2&s=5972c3255bd16d40c1cda6e6e5de4142

Share This:

Leave a Reply

Your email address will not be published. Required fields are marked *